Skip to main content

Redistribution : Rip & OSPF Using Packet Tracer

I was playing around with Packet Tracer today, thought why not give it a try. Nice program none the less. So here is a very modest try on basic redistribution. I thought it will help someone.

The lab had very basic set up, i used three routers and with a bunch of loopbacks i tested the redistribution between RIP and OSPF. You can use this lab as a tester or a reference point. PT lacks a lot of command options but is still very highly usable.

So here is the setup:

Router 1: (RIP V2)

interface Loopback1
ip address 192.168.10.100 255.255.255.0
!
interface Loopback2
ip address 2.2.2.2 255.0.0.0
!
interface Serial0/0
ip address 172.16.10.1 255.255.255.252
!
router rip
version 2
network 2.0.0.0
network 172.16.0.0
network 192.168.10.0
no auto-summary

Router 3: (OSPF 1)

interface Loopback1
ip address 3.3.3.3 255.0.0.0
!
interface Loopback2
ip address 192.168.20.100 255.255.255.0
!
interface Serial0/0
ip address 172.16.20.1 255.255.255.252
clock rate 64000
!
router ospf 1
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 192.168.20.0 0.0.0.255 area 0
network 172.16.20.0 0.0.0.3 area 0

Router 2: (Performed the redistribution)

interface Serial0/0
ip address 172.16.10.2 255.255.255.252
clock rate 64000
!
interface Serial0/1
ip address 172.16.20.2 255.255.255.252
!
router ospf 1
log-adjacency-changes
redistribute rip subnets
network 172.16.20.0 0.0.0.3 area 0
!
router rip
version 2
redistribute ospf 1 metric 5
network 172.16.0.0
no auto-summary

Outputs:

Router 1: (Rip)

Gateway of last resort is not set

C 2.0.0.0/8 is directly connected, Loopback2
3.0.0.0/32 is subnetted, 1 subnets
R 3.3.3.3 [120/5] via 172.16.10.2, 00:00:01, Serial0/0
172.16.0.0/30 is subnetted, 2 subnets
C 172.16.10.0 is directly connected, Serial0/0
R 172.16.20.0 [120/1] via 172.16.10.2, 00:00:01, Serial0/0
C 192.168.10.0/24 is directly connected, Loopback1
192.168.20.0/32 is subnetted, 1 subnets
R 192.168.20.100 [120/5] via 172.16.10.2, 00:00:01, Serial0/0

Router 3: (OSPF)

O E2 2.0.0.0/8 [110/781] via 172.16.20.2, 00:18:56, Serial0/0
C 3.0.0.0/8 is directly connected, Loopback1
172.16.0.0/30 is subnetted, 2 subnets
O E2 172.16.10.0 [110/781] via 172.16.20.2, 00:18:56, Serial0/0
C 172.16.20.0 is directly connected, Serial0/0
O E2 192.168.10.0/24 [110/781] via 172.16.20.2, 00:18:56, Serial0/0
C 192.168.20.0/24 is directly connected, Loopback2

Router 2: (Performed Redistribution)

R 2.0.0.0/8 [120/1] via 172.16.10.1, 00:00:00, Serial0/0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/782] via 172.16.20.1, 00:20:15, Serial0/1
172.16.0.0/30 is subnetted, 2 subnets
C 172.16.10.0 is directly connected, Serial0/0
C 172.16.20.0 is directly connected, Serial0/1
R 192.168.10.0/24 [120/1] via 172.16.10.1, 00:00:00, Serial0/0
192.168.20.0/32 is subnetted, 1 subnets
O 192.168.20.100 [110/782] via 172.16.20.1, 00:20:15, Serial0/1

(The routes that are in bold are learned using redistribution)


Now you could use the "passive-interface" command on s0/1 of Router 2 so that route on s0/1 is advertised by RIP.

If you want the PT lab file, here is the link: hxxp://[nofileshares].com/files/195399030/redist-lab1.pkt.html

Note: As i mentioned above PT does lack some of the advance features. For example while redistributing the rip i was not able to specify the metric-type. But as you can see it still works. :)

Comments

  1. Thanks for it darkloard:) you should have had included a image of your topology. Instead of using redistribution on router 2,we can use default routes on router 1 and router 3.If router1 gets a packet with destination 3.3.3.0( which is on router3) it can forward it to router 2,and if router 3 has a packet with network 2.0.0.0 as destination,so according to the default route it should forward it to router 2 and router 2 will send it to router 1.Redistribution is something very nice to play with :D

    EDIT: what is more feasible in a production environment? configuring a router with ospf and rip to do the distribution or implementing default routes?

    ReplyDelete
  2. And in addition, route redistribution also is helpful when you company has old routers that only supports old routing protocols (e.g RIP v1), so instead of buying a new router, we redistribute route :lol:

    ReplyDelete
  3. Tesla, Sorry the lab layout was so simple i thought a screenshot was not needed. :)

    Now it all depends on what kind of setup you have, there will be times when you have to use route redistribution, for example:

    1) Your company uses OSPF and they just bought an other company that uses a different routing protocol rip, eigrp etc.

    2) Your company wants to expand and the current routing protocol will not be enough (for whatever reasons), so you want to switch to a different protocol. Now you can either shut the whole network down and reconfigure it OR reconfigure one network segment at a time.

    3) Geo-political problems. A routing protocol may not meet the industry standards of certain regions, countries. So you will be forced to use redistribution.

    Route redistribution could be as simple as the example in the first post. But there are a lot of other advance features like filtering that i haven't touched. May be i will post another lab someday.

    ReplyDelete
  4. Thank you! really helpful post... :D

    ReplyDelete
  5. Thank you for your kindness, Jah bless.. you dude..

    ReplyDelete
  6. Alright then, i have posted another lab and the walk through on this topic.

    But i have a feeling redistribution is a little too advance fo CCNA level. But i will post more labs on different technologies in the future. Its good to share you learn a few things too.

    ReplyDelete
  7. sir it would be really good to know regarding what else can be achieved through redistribution,Plz enlighten us :D ,and i doubt if those advanced features work in PT

    ReplyDelete

Post a Comment

Popular posts from this blog

[韓日関係] 首相含む大幅な内閣改造の可能性…早ければ来月10日ごろ=韓国

div not scrolling properly with slimScroll plugin

I am using the slimScroll plugin for jQuery by Piotr Rochala Which is a great plugin for nice scrollbars on most browsers but I am stuck because I am using it for a chat box and whenever the user appends new text to the boxit does scroll using the .scrollTop() method however the plugin's scrollbar doesnt scroll with it and when the user wants to look though the chat history it will start scrolling from near the top. I have made a quick demo of my situation http://jsfiddle.net/DY9CT/2/ Does anyone know how to solve this problem?

Why does this javascript based printing cause Safari to refresh the page?

The page I am working on has a javascript function executed to print parts of the page. For some reason, printing in Safari, causes the window to somehow update. I say somehow, because it does not really refresh as in reload the page, but rather it starts the "rendering" of the page from start, i.e. scroll to top, flash animations start from 0, and so forth. The effect is reproduced by this fiddle: http://jsfiddle.net/fYmnB/ Clicking the print button and finishing or cancelling a print in Safari causes the screen to "go white" for a sec, which in my real website manifests itself as something "like" a reload. While running print button with, let's say, Firefox, just opens and closes the print dialogue without affecting the fiddle page in any way. Is there something with my way of calling the browsers print method that causes this, or how can it be explained - and preferably, avoided? P.S.: On my real site the same occurs with Chrome. In the ex